Front page

Upgrading from 1.6.1 to 1.19.1

8ebf370e2cee48d8a0eca5e70e33855f
ORCA REBELLION CLAMSHELL

From: Jess Harpur <jess.harpur@gmail.com>
Date: Tue, 10 May 2016 08:33:09 +0000 (UTC)

   Hello everyone,
   
   I installed obnam (v1.6.1) via the Software Manager in Mint 17.2, and have 
   successfully created a repository and config files to make a compressed, 
   encrypted backup, which I can also mount with obnam.
   
   I read the 'NEWS' file from obnam v1.19.1-2 (downloaded from Chris Cormack's 
   Launchpad pages), and noted the warning in the v1.7 release notes about 
   backing up my repository before upgrading. Other than that, am I likely to 
   encounter any issues upgrading to v1.19.1?
   
   Any advice gratefully received.
   
   Thanks
   Jess
   
   ps. Can anyone tell me if installing v1.19.1 using the .deb package will 
   upgrade my current installation, or should I uninstall first?
   
   
   _______________________________________________
   obnam-support mailing list
   obnam-support@obnam.org
   http://listmaster.pepperfish.net/cgi-bin/mailman/listinfo/obnam-support-obnam.org
From: Jess Harpur <jess.harpur@gmail.com>
Date: Fri, 13 May 2016 10:37:59 +0000 (UTC)

   Lars Wirzenius <liw <at> liw.fi> writes:
   
   > 
   > On Tue, May 10, 2016 at 08:33:09AM +0000, Jess Harpur wrote:
   > > I read the 'NEWS' file from obnam v1.19.1-2 (downloaded from Chris 
   Cormack's 
   > > Launchpad pages), and noted the warning in the v1.7 release notes about 
   > > backing up my repository before upgrading. Other than that, am I likely 
   to 
   > > encounter any issues upgrading to v1.19.1?
   > 
   > I don't think there are any issues with that upgrade, but I haven't
   > explicitly tested it, either.
   > 
   > > ps. Can anyone tell me if installing v1.19.1 using the .deb package will 
   > > upgrade my current installation, or should I uninstall first?
   > 
   > Just installing the new package version is enough.
   > 
   
   Thanks Lars.
   
   GDebi Package Installer is giving me an error "Dependency is not 
   satisfiable: python-tracing (>=0.8~)" for obnam_1.19.1-2_amd64.deb. I tried 
   'apt-get install python-tracing' but it tells me I have the latest version 
   (0.6-2).
   
   Any suggestions?
   
   Or perhaps I should adhere to the time-honoured principle of "if it ain't 
   broke, don't fix it!" - after all, obnam 1.6.1 is working fine for me.
   
   ~Jess
   
   
   
   _______________________________________________
   obnam-support mailing list
   obnam-support@obnam.org
   http://listmaster.pepperfish.net/cgi-bin/mailman/listinfo/obnam-support-obnam.org
From: Lars Wirzenius <liw@liw.fi>
Date: Fri, 13 May 2016 10:39:06 +0300

   On Tue, May 10, 2016 at 08:33:09AM +0000, Jess Harpur wrote:
   > I read the 'NEWS' file from obnam v1.19.1-2 (downloaded from Chris Cormack's 
   > Launchpad pages), and noted the warning in the v1.7 release notes about 
   > backing up my repository before upgrading. Other than that, am I likely to 
   > encounter any issues upgrading to v1.19.1?
   
   I don't think there are any issues with that upgrade, but I haven't
   explicitly tested it, either.
   
   > ps. Can anyone tell me if installing v1.19.1 using the .deb package will 
   > upgrade my current installation, or should I uninstall first?
   
   Just installing the new package version is enough.
From: Lars Wirzenius <liw@liw.fi>
Date: Fri, 13 May 2016 22:13:32 +0300

   On Fri, May 13, 2016 at 10:37:59AM +0000, Jess Harpur wrote:
   > GDebi Package Installer is giving me an error "Dependency is not 
   > satisfiable: python-tracing (>=0.8~)" for obnam_1.19.1-2_amd64.deb. I tried 
   > 'apt-get install python-tracing' but it tells me I have the latest version 
   > (0.6-2).
   > 
   > Any suggestions?
   > 
   > Or perhaps I should adhere to the time-honoured principle of "if it ain't 
   > broke, don't fix it!" - after all, obnam 1.6.1 is working fine for me.
   
   You will need the right versions of the dependencies Obnam wants,
   including the python-tracing package. I don't know GDebi so I don't
   know how to get it to install those, I'm afraid.