Front page

Obnam and Python 2.x

8eb4c1d345dd435b8eb4724ee14defe0
ORCA POLITENESS SNAPLINE

From: Lars Wirzenius <liw@liw.fi>
Date: Mon, 15 Aug 2016 21:36:19 +0300

   I'd like to drop support for Python 2.6 in Obnam, and in those of its
   dependencies that I wrote myself. In other words, only Python 2.7
   would be supported (and then a "sufficiently new" revision, but I
   don't yet know which one that would be). This is primarily motivated
   as a first step towards starting a Python 3 migration.
   
   Would this be a problem to anyone?
   
   Debian, Ubuntu, Gentoo, and Fedora should all have Python 2.7. I don't
   know how to check openSUSE and CentOS. Those are the systems listed on
   the Obnam download page (http://obnam.org/download/). Can users of
   those systems tell me what version of Python 2 they have?
From: Paul Waring <paul@xk7.net>
Date: Wed, 24 Aug 2016 15:04:55 +0100

   On 15/08/16 19:36, Lars Wirzenius wrote:
   > I'd like to drop support for Python 2.6 in Obnam, and in those of its
   > dependencies that I wrote myself. In other words, only Python 2.7
   > would be supported (and then a "sufficiently new" revision, but I
   > don't yet know which one that would be). This is primarily motivated
   > as a first step towards starting a Python 3 migration.
   >
   > Would this be a problem to anyone?
   >
   > Debian, Ubuntu, Gentoo, and Fedora should all have Python 2.7. I don't
   > know how to check openSUSE and CentOS. Those are the systems listed on
   > the Obnam download page (http://obnam.org/download/). Can users of
   > those systems tell me what version of Python 2 they have?
   
   I have downloaded and installed the latest versions of openSUSE and 
   CentOS, they have the following Python versions by default:
   
   openSUSE: 2.7.12
   
   CentOS: 2.7.5
   
   I'm happy to test other distributions if need be - it doesn't take long 
   for me to boot them in a VM.
   
   Paul
From: Rémi Rampin <remirampin@gmail.com>
Date: Wed, 24 Aug 2016 17:41:09 -0400

   Here's the information I could find:
   
   CentOS 7: 2.7.5
   *CentOS 6.6: 2.6.6*
   Fedora 24: 2.7.12
   Fedora 23: 2.7.11
   Fedora 22: 2.7.9
   Fedora 21: 2.7.8
   Fedora 20: 2.7.5
   OpenSUSE 42.1: 2.7.12
   Ubuntu Xenial: 2.7.11
   Ubuntu Wily: 2.7.9
   Ubuntu Trusty: 2.7.5
   Ubuntu Precise: 2.7.3
   Debian Jessie: 2.7.9
   Debian Wheezy: 2.7.4
   
   Apart from CentOS which is *technically* still supported until next year,
   everybody has switched to Python 2.7.
From: Lars Wirzenius <liw@liw.fi>
Date: Thu, 25 Aug 2016 13:18:40 +0100

   On Wed, Aug 24, 2016 at 05:41:09PM -0400, Rémi Rampin wrote:
   > Here's the information I could find:
   ...
   > Apart from CentOS which is *technically* still supported until next year,
   > everybody has switched to Python 2.7.
   
   Thanks, Rémi and Paul. Looks like I can make Obnam require Python 2.7
   without too much trouble to anyone. This will make porting Obnam to
   Python 3 easier.